coda file system · Maintained
Maintainers
- M Jan Harkes <jaharkes@cs.cmu.edu>
Paths
- F
Documentation/filesystems/coda.rst - F
fs/coda/ - F
include/linux/coda*.h - F
include/uapi/linux/coda*.h
Last 30 days
Recent patches
Most-recent 30 patches in this subsystem on linux-ext4 (capped at 30), ordered by date desc.
-
STALE119d
[PATCH 17/53] coda: don't d_drop() early.
2026-03-12 · NeilBrown <hidden> -
STALE129d
[PATCH v3 12/12] treewide: change inode->i_ino from unsigned long to u64
2026-03-04 · Jeff Layton <jlayton@kernel.org> -
STALE141d
[PATCH v2 077/110] coda: replace PRIino with %llu/%llx format strings
2026-03-02 · Jeff Layton <jlayton@kernel.org> -
STALE141d
[PATCH v2 024/110] coda: use PRIino format for i_ino
2026-03-02 · Jeff Layton <jlayton@kernel.org> -
STALE146d
[PATCH 26/61] coda: update format strings for u64 i_ino
2026-02-26 · Jeff Layton <jlayton@kernel.org> -
STALE232d
REVIEWED: 2 (2M) [PATCH RESEND v3] vfs: remove the excl argument from the ->create() inode_operation
2025-12-01 · Jeff Layton <jlayton@kernel.org> -
DORMANTno replies
REVIEWED: 2 (2M) [PATCH v3] vfs: remove the excl argument from the ->create() inode_operation
2025-11-10 · Jeff Layton <jlayton@kernel.org> -
STALE256d
[PATCH v2] vfs: remove the excl argument from the ->create() inode_operation
2025-11-07 · Jeff Layton <jlayton@kernel.org> -
STALE259d
[PATCH] vfs: remove the excl argument from the ->create() inode_operation
2025-11-05 · Jeff Layton <jlayton@kernel.org> -
STALE276d
[PATCH v7 04/14] Coccinelle-based conversion to use ->i_state accessors
2025-10-09 · Mateusz Guzik <hidden> -
STALE289d
[PATCH v6 2/4] Convert the kernel to use ->i_state accessors
2025-09-23 · Mateusz Guzik <hidden> -
STALE304d
[PATCH v5 2/4] Convert the kernel to use ->i_state accessors
2025-09-19 · Mateusz Guzik <hidden> -
STALE307d
[PATCH v4 03/12] fs: mechanically convert most filesystems to use ->i_state accessors
2025-09-16 · Mateusz Guzik <hidden> -
STALE311d
[PATCH v3 3/4] convert all filesystems to use the new ->i_state accessors
2025-09-11 · Mateusz Guzik <hidden> -
STALE356d
LANDED [PATCH 01/10] mm: rename call_mmap/mmap_prepare to vfs_mmap/mmap_prepare
2025-06-16 · Lorenzo Stoakes <hidden> -
STALE356d
LANDED [PATCH 03/10] fs: consistently use file_has_valid_mmap_hooks() helper
2025-06-16 · Lorenzo Stoakes <hidden> -
STALE1047d
[PATCH 07/11] vfs: add nowait parameter for file_accessed()
2023-08-27 · Hao Xu <hidden> -
STALE1063d
[PATCH 08/29] vfs: add nowait parameter for file_accessed()
2023-08-25 · Hao Xu <hidden> -
STALE919d
[PATCH v6 3/9] fs: Expose name under lookup to d_revalidate hooks
2023-08-16 · Gabriel Krisman Bertazi <hidden> -
STALE1071d
[PATCH v5 04/10] fs: Expose name under lookup to d_revalidate hooks
2023-08-12 · Gabriel Krisman Bertazi <hidden> -
STALE1037d
REVIEWED: 12 (10M) [PATCH v7 02/13] fs: pass the request_mask to generic_fillattr
2023-08-07 · Jeff Layton <jlayton@kernel.org> -
STALE1059d
[PATCH v6 1/7] fs: pass the request_mask to generic_fillattr
2023-07-25 · Jeff Layton <jlayton@kernel.org> -
STALE1101d
[PATCH v5 1/8] fs: pass the request_mask to generic_fillattr
2023-07-13 · Jeff Layton <jlayton@kernel.org> -
STALE1135d
[PATCH v4 1/9] fs: pass the request_mask to generic_fillattr
2023-05-18 · Jeff Layton <jlayton@kernel.org> -
STALE1956d
LANDED: 4 (4M) [PATCH v6 24/40] fs: make helpers idmap mount aware
2021-01-21 · Christian Brauner <hidden> -
STALE1956d
LANDED: 4 (4M) [PATCH v6 11/40] stat: handle idmapped mounts
2021-01-21 · Christian Brauner <hidden> -
STALE2010d
[PATCH v5 32/42] fs: make helpers idmap mount aware
2021-01-12 · Christian Brauner <hidden> -
STALE2010d
[PATCH v5 18/42] stat: handle idmapped mounts
2021-01-12 · Christian Brauner <hidden> -
STALE2053d
[PATCH v4 31/40] fs: make helpers idmap mount aware
2020-12-04 · Christian Brauner <hidden> -
STALE2053d
[PATCH v4 17/40] stat: handle idmapped mounts
2020-12-04 · Christian Brauner <hidden>
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE146d
[PATCH 26/61] coda: update format strings for u64 i_ino
2026-02-26 · Jeff Layton <jlayton@kernel.org> -
STALE141d
[PATCH v2 024/110] coda: use PRIino format for i_ino
2026-03-02 · Jeff Layton <jlayton@kernel.org> -
STALE141d
[PATCH v2 077/110] coda: replace PRIino with %llu/%llx format strings
2026-03-02 · Jeff Layton <jlayton@kernel.org> -
STALE119d
[PATCH 17/53] coda: don't d_drop() early.
2026-03-12 · NeilBrown <hidden>